ActPresentation.com HOME FAQ FORUM info@ActPresentation.com
Phorum: speed & power.

ActPresentation.com


Add-ons for Sage ACT! CRM

ACT! addons by ActPresentation.com : Abacus Calculated Fields, PicturePlus, Quick Navigation List, Employment History, Quick Search, Presentation for ACT!

Yes/No to set field value...

Posted by: pbb

Date: August 23, 2007 12:45PM

Similar to ACT for financial professionals, i have a tab called "Addresses"
In the "addresses" tab, i have the built-in business address fields and the home address fields. Additionally, i have a yes/no field called "Set Business Address to Primary".

In the contact detail layout area, I have a set of fields called: "Primary Address 1", "Primary Address 2", "Primary City", etc.

If the "Set Business Address to Primary" field is checked, i want the primary address fields to equal the business address fields, and if unchecked, then equal to the home address fields.

However, the primary address fields always equal the business address fields regardless of whether the "Set Business Address to Primary" is checked or unchecked.

Here is my "code" for the "Primary Address 1" field:

IF( [Set Business Address to Primary] = 1 ) THEN
[Address 1]
ELSE
[Home Address 1]
END

Have any guidance on what i'm doing wrong?

Home address always = business address?
Posted by: pbb
Date: August 23, 2007 04:43PM

I've posted a couple other topics dealing with looking at a yes/no condition and then setting a new field called "Primary Address 1" equal to either "Address 1" or "Home Address 1". I kept getting "Address 1" value in the "Primary Address 1" field, regardless of whether the yes/no field was checked or unchecked.

I checked the logic by having the "Primary Address 1" field set to a one string if true and another if false and it worked correctly.

Further analysis reviewed that if I set "Primary Address 1" to "Home Address 1", "Primary Address 1" = "Address 1" (with no other formula)

Any ideas?



Edited 1 time(s). Last edit at 08/26/2007 01:57PM by Admin.

Re: Yes/No to set field value...

Posted by: Admin

Date: August 24, 2007 08:52AM

I have to confirm this is a problem in Abacus version 9.x
The problem will be fixed in next version (10.x)
Version 10.x will be released before Sep'1 2007



Edited 1 time(s). Last edit at 08/24/2007 09:44AM by Admin.

ACT! software CRM addons - best plugins for ACT contact management software ( Act! by Sage software : ACT!2005, ACT!2006, ACT!2007, ACT!2008, Act by Sage Premium for Workgroups ).
Custom addon solutions ( ACT! add ons ) development and CRM (Customer Relationship Management) software training and consulting.